您现在的位置是: 首页 > 运维 Redis 提示 MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk 解决方案
Redis 提示 MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk 解决方案
2020-05-21 【运维】 5838人已围观 9607次浏览
简介Redis 提示 MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk 解决方案
在使用 Redis 的过程中提示下面的报错信息
org.springframework.data.redis.RedisSystemException: Error in execution;
nested exception is io.lettuce.core.RedisCommandExecutionException: MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk.
Commands that may modify the data set are disabled, because this instance is configured to report errors during writes if RDB snapshotting fails (stop-writes-on-bgsave-error option).
Please check the Redis logs for details about the RDB error.\norg.springframework.data.redis.RedisSystemException: Error in execution; nested exception is io.lettuce.core.RedisCommandExecutionException: MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk.
Commands that may modify the data set are disabled, because this instance is configured to report errors during writes if RDB snapshotting fails (stop-writes-on-bgsave-error option). Please check the Redis logs for details about the RDB error
大致意思就是说
Redis配置为保存RDB快照,但它当前无法在磁盘上持久化。可以修改数据集的命令被禁用,因为此实例配置为在RDB快照失败时报告写入期间的错误(停止对bgsave error的写入选项)
原因是因为强制关闭 Redis 快照导致不能持久化(之前部署Redis的机器断电过,猜测是因为这个导致的)
解决方案就是重启Redis后,登录进去,将stop-writes-on-bgsave-error设置为no
127.0.0.1:6379> config set stop-writes-on-bgsave-error no
但需要注意的是,执行这个命令只能暂时解决无法 set 的问题,具体的问题还是要看 Redis 的 log 信息详细排查错误才行
很赞哦! (0)
相关文章
- 迁移 Docker 目录
- LNMP 手动更新 SSL 证书
- Docker 批量操作命令
- Linux 常用命令 持续更新中...
- CentOS 安装JDK
- Zookeeper 找不到或无法加载主类 org.apache.zookeeper.server.quorum.QuorumPeerMain
- Linux 修改默认的 ssh 22 端口
- 解决Lost connection to MySQL server at 'reading initial communication packet' 的方法
- ElasticSearch安装踩坑指南
- Linux 服务器之间传输大文件(压缩文件、查看MD5、后台传输)
点击排行
- Error in execution; nested exception is io.lettuce.core.RedisCommandExecutionException: ERR DISABLE You can't write or read against a disable instance
- Debian apt 使用国内镜像
- RocketMQ 出现 sendDefaultImpl call timeout 问题
- 类 BASE64Decoder 程序包 sun.misc 找不到符号
- SpringBoot @NotBlank 不生效问题
- 记一次 Mybatis-Plus 自动填充无效问题解决
- SpringBoot 2.x 文件上传出现 The field file exceeds its maximum permitted size of 1048576 bytes
- nuxt 项目完整部署方案
站长推荐
猜你喜欢
- Redis 提示 MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk 解决方案
- 防止Time Machine备份Parallels Desktop的虚拟硬盘文件
- Vue 监听回车 el-input 和 input 使用方法不同
- Zookeeper 找不到或无法加载主类 org.apache.zookeeper.server.quorum.QuorumPeerMain
- Linux 服务器之间传输大文件(压缩文件、查看MD5、后台传输)
- Win10 安装适用于Linux的Windows子系统
- Vue 路由跳转错误 NavigationDuplicated: Avoided redundant navigation to current location
- nginx 出现 the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in 错误解决方案
- 类 BASE64Decoder 程序包 sun.misc 找不到符号
- 在更新python时出现dyld: Library not loaded: /usr/local/opt/libpsl/lib/libpsl.5.dylib,Reason: image not found错误解决方案